Table of contents
Access Control
Download API definition:
POST https://dev-api.bentley.com/accesscontrol/itwins/{id}/groups

Create a new iTwin group.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

A user can create a Group by being assigned the administration_manage_groups on the iTwin level. A user also can create a Group on an iTwin by either being an Organization Administrator for the Organization that owns the given iTwin, or an owner of the iTwin.

For creation of Groups on the Account iTwin, the user must be an Organization Administrator for the Organization.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Request parameters

Name
Required?
Description
id
Yes

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v2+json is recommended.

Request body

Group (create)

Name
Type
Required?
Description
name
String
Yes

The name of your Group.

description
String
Yes

A description of your Group.

Example

json
{
    "name": "Sample Group",
    "description": "This is a group for created for a sample"
}

Response 201 Created

iTwin group was successfully added.

json
{
    "group": {
        "id": "82156be8-5179-4856-8fdd-802e305f9dfa",
        "name": "Sample Group",
        "description": "This is a group for created for a sample",
        "members": [],
        "imsGroups": []
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 403 Forbidden

The user has insufficient permissions for the requested operation.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

This response indicates the iTwin was not found.

json
{
    "error": {
        "code": "ItwinNotFound",
        "message": "Requested iTwin is not available."
    }
}

Response 422 Unprocessable Entity

Invalid request to create new iTwin group. Make sure request had required properties and does not pass in readonly properties.

json
{
    "error": {
        "code": "InvalidiTwinsGroupRequest",
        "message": "Cannot create/update group.",
        "details": [{
                "code": "MissingRequiredProperty",
                "message": "Required property is missing.",
                "target": "Name"
            },
            {
                "code": "MissingRequiredProperty",
                "message": "Required property is missing.",
                "target": "Description"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Failed to parse request body or collection is empty."
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

GroupResponse

Name
Type
Description
group

Group

Name
Type
Description
id
String

The Group id.

name
String

The name of your Group.

description
String

A description of your Group.

members

List of members assigned to the Group. Max size of 50.

imsGroups
String[]

List of IMS Groups assigned to the Group. Max size of 50.

GroupUser

Name
Type
Description
userId
String

The user Id in Identity Management System.

email
String

User email.

givenName
String

User given name.

surname
String

User surname.

organization
String

Organization user is member of in Identity Management System.

Group (create)

Name
Type
Description
name
String

The name of your Group.

description
String

A description of your Group.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.