Table of contents
Access Control
Download API definition:
GET https://dev-api.bentley.com/accesscontrol/itwins/{id}/members/groups

Retrieves a list of iTwin group members and their roles assignments.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

The calling user must be a member of the iTwin. Organization Administrator can also retrieve iTwin members for any iTwin in their Organization.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Request parameters

Name
Required?
Description
id
Yes

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
No

Setting to application/vnd.bentley.itwin-platform.v2+json is recommended.

Response 200 OK

OK

json
{
    "members": [{
            "id": "99cf5e21-735c-4598-99eb-fe3940f96353",
            "groupName": "Sample Group",
            "groupDescription": "This is a sample group",
            "roles": [{
                    "id": "5abbfcef-0eab-472a-b5f5-5c5a43df34b1",
                    "displayName": "Read Access",
                    "description": "Read Access"
                },
                {
                    "id": "6abbfcea-0eab-472a-b5f5-5c5a43df34b4",
                    "displayName": "Write Access",
                    "description": "Write Access"
                }
            ]
        },
        {
            "id": "25407933-cad2-41a2-acf4-5a074c83046b",
            "groupName": "Another Sample Group",
            "groupDescription": "This is another sample group",
            "roles": [{
                "id": "5abbfcef-0eab-472a-b5f5-5c5a43df34b1",
                "displayName": "Read Access",
                "description": "Read Access"
            }]
        }
    ],
    "_links": {
        "self": {
            "href": "https://api.bentley.com/iTwins/806b19d5-c037-48a4-aa98-e297c81453f1/member/groups?$skip=0&$top=100"
        },
        "prev": {
            "href": "https://api.bentley.com/iTwins/806b19d5-c037-48a4-aa98-e297c81453f1/member/groups?$skip=0&$top=100"
        },
        "next": {
            "href": "https://api.bentley.com/iTwins/806b19d5-c037-48a4-aa98-e297c81453f1/member/groups?$skip=100&$top=100"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that iTwin with specified ID was not found.

json
{
    "error": {
        "code": "ItwinNotFound",
        "message": "Requested iTwin is not available."
    }
}

Response 422 Unprocessable Entity

Invalid request to get iTwin members.

json
{
    "error": {
        "code": "InvalidiTwinsMemberRequest",
        "message": "Request body or query is invalid.",
        "details": [{
                "code": "InvalidValue",
                "message": "Value outside of valid range.",
                "target": "$top"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Failed to parse request body or collection is empty."
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

iTwin Group Member

Name
Type
Description
id
String

The group id.

groupName
String

Group name.

groupDescription
String

Group description.

roles

List of roles.

iTwin Group Members

Name
Type
Description
members

List of group members.

_links

Contains the hyperlinks to the previous and next pages of results.

Role

Name
Type
Description
id
String

The role id.

displayName
String

The display name of your Role.

description
String

A description of your Role.

permissions
String[]

List of permissions assigned to the role.

links (paging)

URLs for redoing the current request, getting to the previous or next page of results, if applicable containg.

Name
Type
Description
self

URL for redoing the current request.

next

URL for getting the next page of results.

prev

URL for getting the previous page of results.

link

Hyperlink container.

Name
Type
Description
href
String

Hyperlink container.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.