Updates a group.
Group Query
The query
parameter of a Group must be a valid ECSQL query.
If a valid ECSQL query is given and the selected class is bis.Element
, or if it is a descendant of the class bis.Element
, the only required column is ECInstanceId
. However, it is recommended to always select at least ECInstanceId
and ECClassId
columns.
SELECT * FROM bis.Element
is a valid query- Assuming that class
Building.Beam
is a descendant of the classbis.Element
, the querySELECT * FROM Building.Beam
is a valid query SELECT ECInstanceId, ECClassId FROM bis.Element
is a valid query- Assuming that class
Building.Beam
is a descendant of the classbis.Element
, the querySELECT ECInstanceId, ECClassId FROM Building.Beam
is valid SELECT ECClassId FROM bis.Element
is not a valid query because ECInstanceId column is missing- Assuming that class
Building.Beam
is a descendant of the classbis.Element
, the querySELECT ECClassId FROM Building.Beam
is not valid because ECInstanceId column is missing - Assuming that
Building.BeamAspect
is an aspect, the querySELECT A.ECInstanceId ECInstanceId FROM bis.Element E JOIN Building.BeamAspect A ON A.Element.id = E.ECInstanceId
is not valid because the selectedECInstanceId
is of the aspect, not the element - Assuming that
Building.BeamAspect
is an aspect, the querySELECT Element.id FROM Building.BeamAspect
is not valid because the selected column's name is notECInstanceId
- Assuming that
Building.BeamAspect
is an aspect, the querySELECT Element.id ECInstanceId FROM Building.BeamAspect
is valid
In all other cases the provided ECSQL query is required to select ECInstanceId
and ECClassId
. If ECClassId
is omitted, the service assumes that query selects elements from the bis.Element
class or its descendants. In some cases the results might be unexpected, e.g., you assume that you are querying bis.ElementAspect
but you only select ECInstanceId
so the service only selects the elements that have a matching ECInstanceId
. Because of this it is always recommended to select both ECInstanceId
and ECClassId
.
If different queries are needed for a single output table, then create multiple groups with those different queries but with the same name for each group. That will cause results of all these queries to be concatenated into a single output table. The output table will have column list equal to a union of all properties of groups with the same name. The result rows will be concatenated one after another. If groups are overlapping and multiple groups select the same element the result will contain duplicates.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_write
permission(s) assigned at the iTwin level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin or iModel.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
"Try it out" Limitations
When you run an Extraction with the "Try it out" function on a mapping that was created or modified by using the "Try it out" function, you are limited to 100 extracted rows for each group. Mapping modification is any POST/DELETE/PATCH/PUT request to any endpoint with the tag "Mappings" or if the URL contains {mappingId}.
Request parameters
The mapping Id.
The group Id.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Group (update)
Name of the group (OData v4 SimpleIdentifier).
Description of the group.
An ECSQL query that represents a collection of iModel elements.
Example
{ "groupName": "AllElements", "description": "Updated description", "query": "SELECT ECInstanceId, ECClassId FROM BisCore.Element", "metadata": [{ "key": "key1", "value": "value1" }, { "key": "key2", "value": "value2" } ] }
Response 200 OK
OK
{ "group": { "id": "08f252c4-ee78-4e2b-9280-f7365400b932", "groupName": "AllElements", "description": "Updated description", "query": "SELECT ECInstanceId, ECClassId FROM BisCore.Element", "metadata": [{ "key": "key1", "value": "value1" }, { "key": "key2", "value": "value2" } ], "_links": { "iModel": { "href": "https://api.bentley.com/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a" }, "mapping": { "href": "https://api.bentley.com/grouping-and-mapping/datasources/imodel-mappings/f1fe5959-35ab-467e-83b8-a679b722d80f" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to update a Group.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified resource was not found.
{ "error": { "code": "MappingNotFound", "message": "Requested Mapping is not available.", "target": "mappingId" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidGroupingAndMappingRequest", "message": "Cannot update Group.", "details": [{ "code": "InvalidValue", "message": "Provided 'groupName' value is not valid. Provided value must be OData V4 SimpleIdentifier.", "target": "groupName" }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Metadata
Group
A group is a collection of design elements from an iModel represented by an ECSQL query. When used for reporting a group represents a single output data table in a report.
The group Id.
Name of the group (OData v4 SimpleIdentifier).
Description of the group. The default value is empty string.
An ECSQL query that represents a collection of iModel elements.
{ "title": "Group", "type": "object", "description": "A group is a collection of design elements from an iModel represented by an ECSQL query. When used for reporting a group represents a single output data table in a report.", "properties": { "id": { "type": "string", "description": "The group Id." }, "groupName": { "type": "string", "description": "Name of the group (OData v4 SimpleIdentifier)." }, "description": { "type": "string", "description": "Description of the group. The default value is empty string." }, "query": { "type": "string", "description": "An ECSQL query that represents a collection of iModel elements." }, "metadata": { "$ref": "#/components/schemas/Metadata", "description": "An array of unique key value pairs." }, "_links": { "$ref": "#/components/schemas/GroupLinks", "description": "Contains contextual hyperlinks to related data." } }, "required": [ "id", "groupName", "description", "query", "_links" ], "additionalProperties": false }
Group (update)
Properties of the group to be updated.
Name of the group (OData v4 SimpleIdentifier).
Description of the group.
An ECSQL query that represents a collection of iModel elements.
{ "title": "Group (update)", "type": "object", "description": "Properties of the group to be updated.", "properties": { "groupName": { "type": "string", "description": "Name of the group (OData v4 SimpleIdentifier).", "nullable": true }, "description": { "type": "string", "description": "Description of the group.", "nullable": true }, "query": { "type": "string", "description": "An ECSQL query that represents a collection of iModel elements.", "nullable": true }, "metadata": { "$ref": "#/components/schemas/Metadata", "description": "An array of unique key value pairs.", "nullable": true } }, "additionalProperties": false }
Group Links
Hyperlinks to related data which complements this entity.
{ "title": "Group Links", "type": "object", "description": "Hyperlinks to related data which complements this entity.", "properties": { "iModel": { "$ref": "#/components/schemas/Link", "description": "Link to retrieve the related iModel." }, "mapping": { "$ref": "#/components/schemas/Link", "description": "Link to retrieve the related mapping." } }, "required": [ "iModel", "mapping" ], "additionalProperties": false }
Group response
Container for a group object.
{ "title": "Group response", "type": "object", "description": "Container for a group object.", "properties": { "group": { "$ref": "#/components/schemas/Group", "description": "Group properties." } }, "required": [ "group" ], "additionalProperties": false }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "title": "Link", "type": "object", "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "required": [ "href" ], "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?