Updates a mapping.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_write
permission(s) assigned at the iTwin level. iModel specific permissions may also be applied at the iModel level if iModel level permissions are enabled.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin or iModel.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Extraction Triggers & Configuration
Mappings can be configured with extractionEnabled
set to true
or false
. true
means that extractions will be automatically executed for the given mapping when a ChangesetGroup is completed (see ChangesetGroupCompletedEvent
). Note: Multiple ChangesetGroups can be completed for a single Synchronization job which will result in multiple automatic extractions.
If extractionEnabled
is set to false
, the automatic extractions are disabled. However, extractions can still be executed for a specific mapping manually using the Run Extraction operation and the mappings
request body parameter. To have a better control over extractions, it is recommended to set extractionEnabled
to false
and manually trigger an extraction when a mapping's extracted data is stale and needs to be refreshed.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
"Try it out" Limitations
When you run an Extraction with the "Try it out" function on a mapping that was created or modified by using the "Try it out" function, you are limited to 100 extracted rows for each group. Mapping modification is any POST/DELETE/PATCH/PUT request to any endpoint with the tag "Mappings" or if the URL contains {mappingId}.
Request parameters
The mapping Id.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Mapping (update)
Name of the mapping (OData v4 SimpleIdentifier).
Description of the mapping.
Value of false
excludes the mapping from the Run Extraction operation and automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional mappings
parameter, the value of extractionEnabled
will be treated as true
for all specified Mappings.
Example
{ "mappingName": "UpdatedName", "description": "Updated description", "extractionEnabled": false }
Response 200 OK
OK
{ "mapping": { "id": "f1fe5959-35ab-467e-83b8-a679b722d80f", "mappingName": "Mapping_name", "description": "Mapping schema for iModel", "extractionEnabled": true, "createdOn": "2021-09-03T10:48:45+00:00", "createdBy": "john.doe@example.com", "modifiedOn": "2022-01-10T13:44:56+00:00", "modifiedBy": "john.doe@example.com", "_links": { "iModel": { "href": "https://api.bentley.com/imodels/70a3d6d3-5385-4bc3-87c4-b6bf106e1c0a" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to update a Mapping.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
Specified Mapping was not found.
{ "error": { "code": "MappingNotFound", "message": "Requested Mapping is not available.", "target": "mappingId" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidGroupingAndMappingRequest", "message": "Cannot update Mapping.", "details": [{ "code": "InvalidValue", "message": "Provided 'mappingName' value is not valid. Provided value must be OData V4 SimpleIdentifier.", "target": "mappingName" }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Mapping
Defines a mapping for an iModel. Each mapping represents a collection of 'Groups'.
The mapping Id.
Name of the mapping (OData v4 SimpleIdentifier).
Description of the mapping.
Value of false
excludes the mapping from the Run Extraction operation and automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional mappings
parameter, the value of extractionEnabled
will be treated as true
for all specified Mappings.
Date when the mapping was created.
Email of the user who created the mapping.
Date when the mapping was last modified.
Email of the user who last modified the mapping.
{ "title": "Mapping", "type": "object", "description": "Defines a mapping for an iModel. Each mapping represents a collection of 'Groups'.", "properties": { "id": { "type": "string", "description": "The mapping Id." }, "mappingName": { "type": "string", "description": "Name of the mapping (OData v4 SimpleIdentifier)." }, "description": { "type": "string", "description": "Description of the mapping." }, "extractionEnabled": { "type": "boolean", "description": "Value of `false` excludes the mapping from the Run Extraction operation and automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional `mappings` parameter, the value of `extractionEnabled` will be treated as `true` for all specified Mappings." }, "createdOn": { "type": "string", "description": "Date when the mapping was created.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "createdBy": { "type": "string", "description": "Email of the user who created the mapping.", "format": "email" }, "modifiedOn": { "type": "string", "description": "Date when the mapping was last modified.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedBy": { "type": "string", "description": "Email of the user who last modified the mapping.", "format": "email" }, "_links": { "$ref": "#/components/schemas/MappingLinks", "description": "Contains contextual hyperlinks to related data." } }, "required": [ "id", "mappingName", "description", "extractionEnabled", "createdOn", "createdBy", "modifiedOn", "modifiedBy", "_links" ], "additionalProperties": false }
Mapping Links
Hyperlinks to related data which complements this entity.
{ "title": "Mapping Links", "type": "object", "description": "Hyperlinks to related data which complements this entity.", "properties": { "iModel": { "$ref": "#/components/schemas/Link", "description": "Link to retrieve the related iModel." } }, "required": [ "iModel" ], "additionalProperties": false }
Mapping (update)
Properties of the mapping to be updated.
Name of the mapping (OData v4 SimpleIdentifier).
Description of the mapping.
Value of false
excludes the mapping from the Run Extraction operation and automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional mappings
parameter, the value of extractionEnabled
will be treated as true
for all specified Mappings.
{ "title": "Mapping (update)", "type": "object", "description": "Properties of the mapping to be updated.", "properties": { "mappingName": { "type": "string", "description": "Name of the mapping (OData v4 SimpleIdentifier).", "nullable": true }, "description": { "type": "string", "description": "Description of the mapping.", "nullable": true }, "extractionEnabled": { "type": "boolean", "description": "Value of `false` excludes the mapping from the Run Extraction operation and automatic Data Extraction execution after new changes to the iModel are ready to be processed. If the Run Extraction operation is executed using the optional `mappings` parameter, the value of `extractionEnabled` will be treated as `true` for all specified Mappings.", "nullable": true } }, "additionalProperties": false }
Mapping response
Container for a mapping object.
{ "title": "Mapping response", "type": "object", "description": "Container for a mapping object.", "properties": { "mapping": { "$ref": "#/components/schemas/Mapping", "description": "Mapping properties." } }, "required": [ "mapping" ], "additionalProperties": false }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "title": "Link", "type": "object", "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "required": [ "href" ], "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?