Returns the information about iModel creation process.
This endpoint should be used to check if iModel creation completed.
Forked and cloned iModels
When an iModel is a clone, the clonedFrom
response entity property will contain information about the source iModel from which this iModel was created, otherwise it will be null
. For more information on iModel cloning please refer to the Clone iModel operation documentation.
When an iModel is a fork, the forkedFrom
response entity property will contain information about the main iModel from which this iModel was created, otherwise it will be null
. For more information on iModel forking please refer to the Fork iModel operation documentation.
To get the details of the source/main iModel use Get iModel Details operation with id value taken from clonedFrom.iModelId
or forkedFrom.iModelId
.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have imodels_webview
permission assigned at the iModel level. If iModel Role permissions at the iModel level are configured, then user must additionally have at least imodels_webview
permission assigned at the iTwin level. If permissions at the iModel level are not configured, then user must have imodels_webview
permission assigned at the iTwin level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin the iModel belongs to.
For more information please refer to Account Administrator documentation section on Access Control API documentation page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
iModel id
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is recommended.
Response 200 OK
OK
{ "createOperation": { "state": "scheduled", "clonedFrom": { "iModelId": "5e19bee0-3aea-4355-a9f0-c6df9989ee7d", "changesetId": "13a61888798b687d41f7c748d7414b428766281f" }, "forkedFrom": null } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Specified iModel was not found.
{ "error": { "code": "iModelNotFound", "message": "Requested iModel is not available." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Create iModel Operation Response
Container for Create iModel Operation object.
{ "type": "object", "title": "Create iModel Operation Response", "description": "Container for Create iModel Operation object.", "properties": { "createOperation": { "$ref": "#/components/schemas/CreateiModelOperation", "description": "Create iModel Operation." } }, "additionalProperties": false }
Create iModel operation state
Indicates the current state of the iModel creation process. 'successful' - iModel creation process completed successfully. 'waitingForFile' - iModel is being created from a Baseline File and the file upload to file storage has not been completed yet. scheduled
- iModel creation process is scheduled or in progress. This means that the iModel was created using one of the following methods that require background processing: creating an iModel from Baseline File, cloning an iModel, creating an iModel from template. failed
- iModel creation process failed. mainIModelIsMissingFederationGuids
- iModel fork creation failed because some elements in the main iModel do not have FederationGuid property set.
{ "type": "string", "description": "Indicates the current state of the iModel creation process. 'successful' - iModel creation process completed successfully. 'waitingForFile' - iModel is being created from a Baseline File and the file upload to file storage has not been completed yet. `scheduled` - iModel creation process is scheduled or in progress. This means that the iModel was created using one of the following methods that require background processing: [creating an iModel from Baseline File](https://developer.bentley.com/apis/imodels-v2/operations/create-imodel/#createanimodelusingabaselinefile), [cloning an iModel](https://developer.bentley.com/apis/imodels-v2/operations/clone-imodel/), [creating an iModel from template](https://developer.bentley.com/apis/imodels-v2/operations/create-imodel/#createanimodelfromanexistingimodel). `failed` - iModel creation process failed. `mainIModelIsMissingFederationGuids` - iModel fork creation failed because some elements in the main iModel do not have [FederationGuid](https://www.itwinjs.org/bis/guide/fundamentals/federationguids/) property set.", "enum": [ "successful", "waitingForFile", "scheduled", "failed", "mainIModelIsMissingFederationGuids" ], "title": "Create iModel operation state" }
Create iModel operation
Information about iModel creation process.
Indicates the current state of the iModel creation process. 'successful' - iModel creation process completed successfully. 'waitingForFile' - iModel is being created from a Baseline File and the file upload to file storage has not been completed yet. scheduled
- iModel creation process is scheduled or in progress. This means that the iModel was created using one of the following methods that require background processing: creating an iModel from Baseline File, cloning an iModel, creating an iModel from template. failed
- iModel creation process failed. mainIModelIsMissingFederationGuids
- iModel fork creation failed because some elements in the main iModel do not have FederationGuid property set.
Information about the source iModel of an iModel clone. If the iModel is not created using Clone iModel operation, the value of this property will be null
.
Information about the main iModel of an iModel fork. If the iModel is not created using Fork iModel operation, the value of this property will be null
.
{ "type": "object", "title": "Create iModel operation", "description": "Information about iModel creation process.", "properties": { "state": { "type": "string", "description": "Indicates the current state of the iModel creation process. 'successful' - iModel creation process completed successfully. 'waitingForFile' - iModel is being created from a Baseline File and the file upload to file storage has not been completed yet. `scheduled` - iModel creation process is scheduled or in progress. This means that the iModel was created using one of the following methods that require background processing: [creating an iModel from Baseline File](https://developer.bentley.com/apis/imodels-v2/operations/create-imodel/#createanimodelusingabaselinefile), [cloning an iModel](https://developer.bentley.com/apis/imodels-v2/operations/clone-imodel/), [creating an iModel from template](https://developer.bentley.com/apis/imodels-v2/operations/create-imodel/#createanimodelfromanexistingimodel). `failed` - iModel creation process failed. `mainIModelIsMissingFederationGuids` - iModel fork creation failed because some elements in the main iModel do not have [FederationGuid](https://www.itwinjs.org/bis/guide/fundamentals/federationguids/) property set.", "enum": [ "successful", "waitingForFile", "scheduled", "failed", "mainIModelIsMissingFederationGuids" ], "title": "Create iModel operation state", "$ref": "#/components/schemas/CreateiModelOperation-state" }, "clonedFrom": { "$ref": "#/components/schemas/ClonedFrom", "description": "Information about the source iModel of an iModel clone. If the iModel is not created using [Clone iModel](https://developer.bentley.com/apis/imodels-v2/operations/clone-imodel/) operation, the value of this property will be `null`." }, "forkedFrom": { "$ref": "#/components/schemas/ForkedFrom", "description": "Information about the main iModel of an iModel fork. If the iModel is not created using [Fork iModel](https://developer.bentley.com/apis/imodels-v2/operations/clone-fork/) operation, the value of this property will be `null`." } }, "additionalProperties": false }
Cloned From
Information about the source iModel of an iModel clone. This information will only be returned for iModels created using Clone iModel operation.
Id of the source iModel.
Id of the latest source iModel Changeset which was copied to this iModel. This corresponds to the Changeset specified in changesetId
or changesetIndex
properties when cloning an iModel. If changesetId
is an empty string it means that no Changesets were copied from the source iModel to this one, only iModel Baseline.
{ "type": "object", "title": "Cloned From", "description": "Information about the source iModel of an iModel clone. This information will only be returned for iModels created using [Clone iModel](https://developer.bentley.com/apis/imodels-v2/operations/clone-imodel/) operation.", "properties": { "iModelId": { "type": "string", "description": "Id of the source iModel." }, "changesetId": { "type": "string", "description": "Id of the latest source iModel Changeset which was copied to this iModel. This corresponds to the Changeset specified in `changesetId` or `changesetIndex` properties when [cloning an iModel](https://developer.bentley.com/apis/imodels-v2/operations/clone-imodel/#request-body-cloneimodel). If `changesetId` is an empty string it means that no Changesets were copied from the source iModel to this one, only iModel Baseline." } }, "required": [ "iModelId", "changesetId" ], "additionalProperties": false }
Forked From
Information about the main iModel of an iModel fork. This information will only be returned for iModels created using Fork iModel operation.
Id of the main iModel.
Id of the latest main iModel Changeset which was copied to this iModel. This corresponds to the Changeset specified in changesetId
or changesetIndex
properties when forking an iModel. If changesetId
is an empty string it means that no Changesets were copied from the main iModel to this one, only iModel Baseline.
Id of the Relationship entity that links main and fork iModels.
{ "type": "object", "title": "Forked From", "description": "Information about the main iModel of an iModel fork. This information will only be returned for iModels created using [Fork iModel](https://developer.bentley.com/apis/imodels-v2/operations/fork-imodel/) operation.", "properties": { "iModelId": { "type": "string", "description": "Id of the main iModel." }, "changesetId": { "type": "string", "description": "Id of the latest main iModel Changeset which was copied to this iModel. This corresponds to the Changeset specified in `changesetId` or `changesetIndex` properties when [forking an iModel](https://developer.bentley.com/apis/imodels-v2/operations/fork-imodel/#request-body-forkimodel). If `changesetId` is an empty string it means that no Changesets were copied from the main iModel to this one, only iModel Baseline." }, "relationshipId": { "type": "string", "description": "Id of the Relationship entity that links main and fork iModels." } }, "required": [ "iModelId", "changesetId", "relationshipId" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?