Creates a group. A group is a collection of design elements from an iModel represented by an ECSQL query.
Group Query
The query
parameter of a Group must be a valid ECSQL query.
If a valid ECSQL query is given and the selected class is bis.Element
, or if it is a descendant of the class bis.Element
, the only required column is ECInstanceId
. However, it is recommended to always select at least ECInstanceId
and ECClassId
columns.
SELECT * FROM bis.Element
is a valid query- Assuming that class
Building.Beam
is a descendant of the classbis.Element
, the querySELECT * FROM Building.Beam
is a valid query SELECT ECInstanceId, ECClassId FROM bis.Element
is a valid query- Assuming that class
Building.Beam
is a descendant of the classbis.Element
, the querySELECT ECInstanceId, ECClassId FROM Building.Beam
is valid SELECT ECClassId FROM bis.Element
is not a valid query because ECInstanceId column is missing- Assuming that class
Building.Beam
is a descendant of the classbis.Element
, the querySELECT ECClassId FROM Building.Beam
is not valid because ECInstanceId column is missing - Assuming that
Building.BeamAspect
is an aspect, the querySELECT A.ECInstanceId ECInstanceId FROM bis.Element E JOIN Building.BeamAspect A ON A.Element.id = E.ECInstanceId
is not valid because the selectedECInstanceId
is of the aspect, not the element - Assuming that
Building.BeamAspect
is an aspect, the querySELECT Element.id FROM Building.BeamAspect
is not valid because the selected column's name is notECInstanceId
- Assuming that
Building.BeamAspect
is an aspect, the querySELECT Element.id ECInstanceId FROM Building.BeamAspect
is valid
In all other cases the provided ECSQL query is required to select ECInstanceId
and ECClassId
. If ECClassId
is omitted, the service assumes that query selects elements from the bis.Element
class or its descendants. In some cases the results might be unexpected, e.g., you assume that you are querying bis.ElementAspect
but you only select ECInstanceId
so the service only selects the elements that have a matching ECInstanceId
. Because of this it is always recommended to select both ECInstanceId
and ECClassId
.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must have insights_modify
permission(s) assigned at the iTwin level.
Alternatively the user should be an Organization Administrator for the Organization that owns a given iTwin or iModel.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Group (create)
The iTwin Id.
Name of the group. Must be unique within the iTwin. Name comparisons for ensuring uniqueness are case insensitive.
Description of the group. The default value is empty string.
An ECSQL query that represents a collection of iModel elements.
Example
{ "iTwinId": "3fa85f64-5717-4562-b3fc-2c963f66afa6", "displayName": "PhysicalElements", "description": "A group of physical elements", "query": "SELECT ECInstanceId, ECClassId FROM BisCore.PhysicalElement", "metadata": [{ "key": "key1", "value": "value1" }, { "key": "key2", "value": "value2" } ] }
Response 201 Created
OK
{ "group": { "id": "08f252c4-ee78-4e2b-9280-f7365400b932", "displayName": "PhysicalElements", "description": "A group of physical elements", "query": "SELECT ECInstanceId, ECClassId FROM BisCore.PhysicalElement", "metadata": [{ "key": "key1", "value": "value1" }, { "key": "key2", "value": "value2" } ], "createdDateTime": "2021-09-03T10:48:45+00:00", "modifiedDateTime": "2022-01-10T13:44:56+00:00", "_links": { "iTwin": { "href": "https://api.bentley.com/itwins/3fa85f64-5717-4562-b3fc-2c963f66afa6" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to create a Group.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 409 Conflict
Specified group already exists.
{ "error": { "code": "GroupExists", "message": "Group 'PhysicalElements' already exists.", "target": "displayName" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidNamedGroupsRequest", "message": "Cannot create Group.", "details": [{ "code": "MissingRequiredProperty", "message": "Required property is missing.", "target": "displayName" }] } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Group Metadata Entry
Keys must be unique within the Metadata array.
{ "title": "Group Metadata Entry", "type": "object", "properties": { "key": { "type": "string", "description": "Keys must be unique within the Metadata array." }, "value": { "type": "string", "nullable": true } }, "required": [ "key" ], "additionalProperties": false }
Group (create)
Properties of the group to be created.
The iTwin Id.
Name of the group. Must be unique within the iTwin. Name comparisons for ensuring uniqueness are case insensitive.
Description of the group. The default value is empty string.
An ECSQL query that represents a collection of iModel elements.
{ "title": "Group (create)", "type": "object", "description": "Properties of the group to be created.", "properties": { "iTwinId": { "type": "string", "description": "The iTwin Id." }, "displayName": { "type": "string", "description": "Name of the group. Must be unique within the iTwin. Name comparisons for ensuring uniqueness are case insensitive." }, "description": { "type": "string", "description": "Description of the group. The default value is empty string.", "nullable": true }, "query": { "type": "string", "description": "An ECSQL query that represents a collection of iModel elements." }, "metadata": { "type": "array", "description": "An array of unique key value pairs.", "items": { "$ref": "#/components/schemas/GroupMetadataEntry" }, "nullable": true } }, "required": [ "iTwinId", "displayName", "query" ], "additionalProperties": false }
Group Links
Hyperlinks to related data which complements this entity.
{ "title": "Group Links", "type": "object", "description": "Hyperlinks to related data which complements this entity.", "properties": { "iTwin": { "$ref": "#/components/schemas/Link", "description": "Link to retrieve the related iTwin." } }, "required": [ "iTwin" ], "additionalProperties": false }
Group
A group is a collection of design elements from an iModel represented by an ECSQL query.
The group Id.
Name of the group.
Description of the group. The default value is empty string.
An ECSQL query that represents a collection of iModel elements.
Date when the named group was created.
Date when the named group was modified.
{ "title": "Group", "type": "object", "description": "A group is a collection of design elements from an iModel represented by an ECSQL query.", "properties": { "id": { "type": "string", "description": "The group Id." }, "displayName": { "type": "string", "description": "Name of the group." }, "description": { "type": "string", "description": "Description of the group. The default value is empty string." }, "query": { "type": "string", "description": "An ECSQL query that represents a collection of iModel elements." }, "metadata": { "type": "array", "description": "An array of unique key value pairs.", "items": { "$ref": "#/components/schemas/GroupMetadataEntry" }, "nullable": true }, "createdDateTime": { "type": "string", "description": "Date when the named group was created.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000+00:00" }, "modifiedDateTime": { "type": "string", "description": "Date when the named group was modified.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000+00:00" }, "_links": { "$ref": "#/components/schemas/NamedGroupLinks", "description": "Contains contextual hyperlinks to related data." } }, "required": [ "id", "displayName", "description", "query", "_links" ], "additionalProperties": false }
Group response
Container for a group object.
{ "title": "Group response", "type": "object", "description": "Container for a group object.", "properties": { "group": { "$ref": "#/components/schemas/NamedGroupResponse", "description": "Group properties." } }, "required": [ "group" ], "additionalProperties": false }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "title": "Link", "type": "object", "description": "Hyperlink container.", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "required": [ "href" ], "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?