Returns all PnID Inference Inputs.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Request parameters
Id of the created PnID Inference.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v2+json
is required.
Response 200 OK
List of PnID Inference Inputs returned successfully.
{ "inputs": [{ "id": "cG5pZC5wZGY-", "filename": "pnid.pdf", "size": 100, "_links": { "input": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs/cG5pZC5wZGY-" }, "content": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs/cG5pZC5wZGY-/content" } } }], "_links": { "self": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs" }, "inference": { "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3" } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
Specified Inference was not found.
{ "error": { "code": "PnIDInferenceRunNotFound", "message": "Requested PnID Inference Run is not available." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "title": "Link", "description": "Hyperlink container.", "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false }
PnID Inference Input Links
Contains the hyperlinks to related data of PnID Inference Inputs.
{ "type": "object", "title": "PnID Inference Input Links", "description": "Contains the hyperlinks to related data of PnID Inference Inputs.", "properties": { "input": { "$ref": "#/components/schemas/Link", "description": "URL for deleting uploaded input file." }, "content": { "$ref": "#/components/schemas/Link", "description": "Information about uploaded input content." } }, "additionalProperties": false }
PnID Inference Input
Represents input file for PnID Inference.
File Id of PnID Inference Input
Filename of PnID Inference Input.
File size of PnID Inference Input.
{ "title": "PnID Inference Input", "description": "Represents input file for PnID Inference.", "type": "object", "properties": { "id": { "type": "string", "description": "File Id of PnID Inference Input" }, "filename": { "type": "string", "description": "Filename of PnID Inference Input." }, "size": { "type": "integer", "format": "int64", "description": "File size of PnID Inference Input." }, "_links": { "$ref": "#/components/schemas/PnIDInferenceInputContentLinks" } }, "required": [ "id", "filename", "size" ], "additionalProperties": false }
Paging Links with inference link
URL for getting inference.
{ "title": "Paging Links with inference link", "type": "object", "description": "URL for getting inference.", "properties": { "self": { "description": "URL for getting the previous page of results.", "$ref": "#/components/schemas/Link" }, "inference": { "description": "URL for getting inference", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
PnID Inference Input Page
List of PnID Inference Inputs.
{ "type": "object", "title": "PnID Inference Input Page", "description": "List of PnID Inference Inputs.", "properties": { "inputs": { "type": "array", "description": "Container for PnID Inference Inputs.", "items": { "$ref": "#/components/schemas/PnIDInferenceInputItem" } }, "_links": { "description": "URL for getting inference.", "$ref": "#/components/schemas/PageLinksWithInference" } }, "required": [ "_links", "inputs" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?