Table of contents
Schedules
Download API definition:
This API is a Technical Preview and is available for testing purposes only. Do not use in production.
GET https://dev-api.bentley.com/schedules/{scheduleId}/animation-3d-path-assignments[?$top][&$continuationToken]

Gets all Animation 3D Path Assignments of a Schedule.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Animation 3D Path Assignment Alignment

Animation 3D Path Assignment Alignment describes the position of the assigned object relative to the Animation 3D Path.

  • Center: The center point of the object is aligned to the Animation 3D Path.
  • Custom: The alignment is defined manually by setting the X Y and Z properties.
  • Original: The object starts from it's original position.
  • MinX: The right side of the object's bounding box is aligned with the Animation 3D Path.
  • MaxX: The left side of the object's bounding box is aligned with the Animation 3D Path.
  • MinY: The back of the object's bounding box is aligned with the Animation 3D Path.
  • MaxY: The front of the object's bounding box is aligned with the Animation 3D Path.
  • MinZ: The top of the object's bounding box is aligned with the Animation 3D Path.
  • MaxZ: The bottom of the object's bounding box is aligned with the Animation 3D Path.

Rate limits

All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.

Request parameters

Name
Required?
Description
scheduleId
Yes

The unique identifier of the Schedule.

$top
No

The $top system query option requests the number of items in the queried collection to be included in the result. When $top parameter is not provided default is set to 100. $top value cannot exceed 10000.

$continuationToken
No

A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.

Request headers

Name
Required?
Description
If-None-Match
No

A header that makes the request conditional. If the ETag of the requested resource or resource collection matches the provided value, a 304 (Not Modified) response is returned. For more information see the official documentation.

Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "animation3dPathAssignments": [{
            "adjustForTaskPercentComplete": false,
            "alignment": "MinZ",
            "center": {
                "x": 0,
                "y": 0,
                "z": 0
            },
            "id": "8cc4bf37-20a4-41db-8111-322ed94cc4be",
            "motionEnd": 1,
            "motionStart": 0,
            "pathId": "263fbc39-5936-4dce-be8a-8149c6137c74",
            "pauseDuringNonWorkingTime": false,
            "reverseDirection": true
        },
        {
            "adjustForTaskPercentComplete": false,
            "alignment": "Custom",
            "center": {
                "x": 1,
                "y": 2.5,
                "z": -5
            },
            "id": "95ab86fe-7150-4115-b4b0-b39f02755c65",
            "motionEnd": 0.9,
            "motionStart": 0.1,
            "pathId": "bb0f45bf-8d1f-41bf-9935-b4ec0e870186",
            "pauseDuringNonWorkingTime": true,
            "reverseDirection": true
        }
    ],
    "_links": {
        "self": {
            "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/animation-3d-path-assignments?$top=2"
        },
        "next": {
            "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/animation-3d-path-assignments?$top=2&$continuationToken=eyJQcmltYXJ5U2tpcFRva2VuIjoiMDAwNGE5MDAtM2UxYy00NGNlLThhMzktYWUxZWRlY2M1MWY0IiwiU2Vjb25kYXJ5U2tpcFRva2VuIjpudWxsfQ=="
        }
    }
}

Response headers

Name
Description
Continuation-Token

A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.

ETag

A header that identifies a specific version of a resource or resource collection. For more information see the official documentation.

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the provided Schedule is not available.

json
{
    "error": {
        "code": "ScheduleNotFound",
        "message": "Requested Schedule is not available.",
        "target": "scheduleId"
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidSchedulesRequest",
        "details": [{
                "code": "InvalidValue",
                "message": "Top value is not positive, or exceeds maximum page size.",
                "target": "$top"
            },
            {
                "code": "InvalidValue",
                "message": "Provided continuation token is invalid.",
                "target": "$continuationToken"
            }
        ],
        "message": "The request contains invalid properties."
    }
}

Response 429 Too many requests

This response indicates that the client sent more requests than allowed by this API for the current tier of the client.

json
{
    "error": {
        "code": "RateLimitExceeded",
        "message": "The client sent more requests than allowed by this API for the current tier of the client."
    }
}

Response headers

Name
Description
retry-after

Number of seconds to wait until client is allowed to make more requests.

Animation 3D Path Assignment

Properties related to assignment of an Animation 3D Path.

Name
Type
Description
adjustForTaskPercentComplete
Boolean

When this value is enabled the motion is affected by the Task percent complete.

alignment

Value describing the alignment of the assigned objects to the path.

center

The offset of assigned object from the Animation 3D Path. The coordinate values are relative to the Animation 3D Path. Should only be used when alignment is set to Custom.

id
String

The unique identifier of the Animation 3D Path Assignment.

motionEnd
Double

Decimal value describing where on the 3D Path the object should start. This can be used if the object should only travel a portion of the distance. Value is in range [0, 1].

motionStart
Double

Decimal value describing where on the 3D Path the object should stop. This can be used if the object should only travel a portion of the distance. Value is in range [0, 1].

pathId
String

The unique identifier of the Animation 3D Path.

pauseDuringNonWorkingTime
Boolean

When this value is enabled the motion will be paused during non working hours.

reverseDirection
Boolean

Value specifying if the direction of the Animation 3d Path should be reversed.

Animation 3D Path Assignment Alignment

Animation 3D Path Assignment Alignment describes the position of the assigned object relative to the Animation 3D Path. See the Animation 3D Path Assignment Alignment section for details.

Name
Type
Description
Unknown
String
Original
String
Center
String
Custom
String
MinX
String
MaxX
String
MinY
String
MaxY
String
MinZ
String
MaxZ
String

Animation 3D Path Assignments Response

List of Animation 3D Path Assignments.

Name
Type
Description
animation3dPathAssignments

A list of Animation 3D Path Assignments.

_links

Contains the hyperlinks to the current and next pages of results.

Link

Hyperlink container.

Name
Type
Description
href
String

Hyperlink to the specific entity.

Paging Links

URLs for redoing the current request and/or getting the next page of results if applicable.

Name
Type
Description
self

Relative URL for redoing the current request.

next
Link, null

Relative URL for getting the next page of results.

Point 3D

Name
Type
Description
x
Double

The X coordinate.

y
Double

The Y coordinate.

z
Double

The Z coordinate.

DetailedError

Contains error information and an array of more specific errors.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

details

Optional array of more specific errors.

Detailed Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error Detailed information.

Error

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.

Was this page helpful?