Gets the details of an Animation 3D Path Assignment.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Animation 3D Path Assignment Alignment
Animation 3D Path Assignment Alignment describes the position of the assigned object relative to the Animation 3D Path.
- Center: The center point of the object is aligned to the Animation 3D Path.
- Custom: The alignment is defined manually by setting the X Y and Z properties.
- Original: The object starts from it's original position.
- MinX: The right side of the object's bounding box is aligned with the Animation 3D Path.
- MaxX: The left side of the object's bounding box is aligned with the Animation 3D Path.
- MinY: The back of the object's bounding box is aligned with the Animation 3D Path.
- MaxY: The front of the object's bounding box is aligned with the Animation 3D Path.
- MinZ: The top of the object's bounding box is aligned with the Animation 3D Path.
- MaxZ: The bottom of the object's bounding box is aligned with the Animation 3D Path.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
The unique identifier of the Animation 3D Path Assignment.
Request headers
A header that makes the request conditional. If the ETag of the requested resource or resource collection matches the provided value, a 304 (Not Modified) response is returned. For more information see the official documentation.
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "animation3dPathAssignment": { "adjustForTaskPercentComplete": true, "alignment": "Original", "center": { "x": 0, "y": 0, "z": 0 }, "id": "b1f5e643-3ffe-4510-b56e-c2b39fee1131", "motionEnd": 1, "motionStart": 0, "pathId": "263fbc39-5936-4dce-be8a-8149c6137c74", "pauseDuringNonWorkingTime": false, "reverseDirection": false } }
Response headers
A header that identifies a specific version of a resource or resource collection. For more information see the official documentation.
Response 304 Not Modified
Not Modified
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
This response indicates that the provided Animation 3D Path Assignment or Schedule is not available.
{ "error": { "code": "Animation3dPathAssignmentNotFound", "message": "Requested Animation 3D Path Assignment is not available.", "target": "animation3dPathAssignmentId" } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Animation 3D Path Assignment
Properties related to assignment of an Animation 3D Path.
When this value is enabled the motion is affected by the Task percent complete.
Value describing the alignment of the assigned objects to the path.
The offset of assigned object from the Animation 3D Path. The coordinate values are relative to the Animation 3D Path. Should only be used when alignment is set to Custom.
The unique identifier of the Animation 3D Path Assignment.
Decimal value describing where on the 3D Path the object should start. This can be used if the object should only travel a portion of the distance. Value is in range [0, 1].
Decimal value describing where on the 3D Path the object should stop. This can be used if the object should only travel a portion of the distance. Value is in range [0, 1].
The unique identifier of the Animation 3D Path.
When this value is enabled the motion will be paused during non working hours.
Value specifying if the direction of the Animation 3d Path should be reversed.
{ "title": "Animation 3D Path Assignment", "type": "object", "properties": { "adjustForTaskPercentComplete": { "type": "boolean", "description": "When this value is enabled the motion is affected by the Task percent complete." }, "alignment": { "$ref": "#/components/schemas/Animation3dPathAssignmentAlignment", "description": "Value describing the alignment of the assigned objects to the path." }, "center": { "$ref": "#/components/schemas/Point3", "description": "The offset of assigned object from the Animation 3D Path. The coordinate values are relative to the Animation 3D Path. Should only be used when alignment is set to Custom." }, "id": { "type": "string", "description": "The unique identifier of the Animation 3D Path Assignment." }, "motionEnd": { "type": "number", "description": "Decimal value describing where on the 3D Path the object should start. This can be used if the object should only travel a portion of the distance. Value is in range [0, 1].", "format": "double" }, "motionStart": { "type": "number", "description": "Decimal value describing where on the 3D Path the object should stop. This can be used if the object should only travel a portion of the distance. Value is in range [0, 1].", "format": "double" }, "pathId": { "type": "string", "description": "The unique identifier of the Animation 3D Path." }, "pauseDuringNonWorkingTime": { "type": "boolean", "description": "When this value is enabled the motion will be paused during non working hours." }, "reverseDirection": { "type": "boolean", "description": "Value specifying if the direction of the Animation 3d Path should be reversed." } }, "additionalProperties": false, "description": "Properties related to assignment of an Animation 3D Path." }
Animation 3D Path Assignment Alignment
Animation 3D Path Assignment Alignment describes the position of the assigned object relative to the Animation 3D Path. See the Animation 3D Path Assignment Alignment section for details.
{ "title": "Animation 3D Path Assignment Alignment", "enum": [ "Unknown", "Original", "Center", "Custom", "MinX", "MaxX", "MinY", "MaxY", "MinZ", "MaxZ" ], "type": "string", "description": "Animation 3D Path Assignment Alignment describes the position of the assigned object relative to the Animation 3D Path. See the [Animation 3D Path Assignment Alignment](#animation-3d-path-assignment-alignment) section for details." }
Animation 3D Path Assignment Response
Container for Animation 3D Path Assignment object.
{ "title": "Animation 3D Path Assignment Response", "type": "object", "properties": { "animation3dPathAssignment": { "$ref": "#/components/schemas/Animation3dPathAssignment", "description": "Animation 3D Path Assignment properties." } }, "additionalProperties": false, "description": "Container for Animation 3D Path Assignment object." }
Point 3D
The X coordinate.
The Y coordinate.
The Z coordinate.
{ "title": "Point 3D", "type": "object", "properties": { "x": { "type": "number", "description": "The X coordinate.", "format": "double" }, "y": { "type": "number", "description": "The Y coordinate.", "format": "double" }, "z": { "type": "number", "description": "The Z coordinate.", "format": "double" } }, "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?