Gets all Animation 3D Path Keyframes of a Schedule.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
The $top system query option requests the number of items in the queried collection to be included in the result. When $top parameter is not provided default is set to 100. $top value cannot exceed 10000.
A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.
Request headers
A header that makes the request conditional. If the ETag of the requested resource or resource collection matches the provided value, a 304 (Not Modified) response is returned. For more information see the official documentation.
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "keyframes": [{ "pathId": "bb0f45bf-8d1f-41bf-9935-b4ec0e870186", "position": { "x": -37.8, "y": -18.8, "z": 0 }, "rotation": { "angle": 45, "x": 1, "y": 0, "z": 0 }, "time": 0 }, { "pathId": "263fbc39-5936-4dce-be8a-8149c6137c74", "position": { "x": -18.6, "y": 26.6, "z": -12.2 }, "rotation": { "angle": 0, "x": 1, "y": 0, "z": 0 }, "time": 0.2 } ], "_links": { "self": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/animation-3d-paths/keyframes?$top=2" }, "next": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/animation-3d-paths/keyframes?$top=2&$continuationToken=eyJQcmltYXJ5U2tpcFRva2VuIjoiMDAwNGE5MDAtM2UxYy00NGNlLThhMzktYWUxZWRlY2M1MWY0IiwiU2Vjb25kYXJ5U2tpcFRva2VuIjpudWxsfQ==" } } }
Response headers
A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.
A header that identifies a specific version of a resource or resource collection. For more information see the official documentation.
Response 304 Not Modified
Not Modified
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
This response indicates that the provided Schedule is not available.
{ "error": { "code": "ScheduleNotFound", "message": "Requested Schedule is not available.", "target": "scheduleId" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidSchedulesRequest", "details": [{ "code": "InvalidValue", "message": "Top value is not positive, or exceeds maximum page size.", "target": "$top" }, { "code": "InvalidValue", "message": "Provided continuation token is invalid.", "target": "$continuationToken" } ], "message": "The request contains invalid properties." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Animation 3D Path Keyframe
Representation of an Animation 3D Path Keyframe.
The unique identifier of the Animation 3D Path.
The time of the Animation 3D Path Keyframe as a fraction of the total Animation 3D Path duration. Value is in range [0, 1].
{ "title": "Animation 3D Path Keyframe", "type": "object", "properties": { "pathId": { "type": "string", "description": "The unique identifier of the Animation 3D Path." }, "position": { "$ref": "#/components/schemas/Point3", "description": "The position of the Animation 3D Path Keyframe." }, "rotation": { "$ref": "#/components/schemas/Rotation", "description": "The rotation of assigned object at the time of the Animation 3D Path Keyframe." }, "time": { "type": "number", "description": "The time of the Animation 3D Path Keyframe as a fraction of the total Animation 3D Path duration. Value is in range [0, 1].", "format": "double" } }, "additionalProperties": false, "description": "Representation of an Animation 3D Path Keyframe." }
Animation 3D Path Keyframes Response
List of Animation 3D Path Keyframes.
{ "title": "Animation 3D Path Keyframes Response", "type": "object", "properties": { "keyframes": { "type": "array", "items": { "$ref": "#/components/schemas/Animation3dPathKeyframe" }, "description": "A list of Animation 3D Path Keyframes." }, "_links": { "$ref": "#/components/schemas/PagingLinks", "description": "Contains the hyperlinks to the current and next pages of results." } }, "additionalProperties": false, "description": "List of Animation 3D Path Keyframes." }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false, "description": "Hyperlink container." }
Paging Links
URLs for redoing the current request and/or getting the next page of results if applicable.
{ "title": "Paging Links", "type": "object", "properties": { "self": { "$ref": "#/components/schemas/Link", "description": "Relative URL for redoing the current request." }, "next": { "$ref": "#/components/schemas/Link", "description": "Relative URL for getting the next page of results.", "nullable": true } }, "additionalProperties": false, "description": "URLs for redoing the current request and/or getting the next page of results if applicable." }
Point 3D
The X coordinate.
The Y coordinate.
The Z coordinate.
{ "title": "Point 3D", "type": "object", "properties": { "x": { "type": "number", "description": "The X coordinate.", "format": "double" }, "y": { "type": "number", "description": "The Y coordinate.", "format": "double" }, "z": { "type": "number", "description": "The Z coordinate.", "format": "double" } }, "additionalProperties": false }
Rotation
Properties describing an objects' rotation.
The rotation angle.
The X rotation axis. Should be normalized (X^2 + Y^2 + Z^2 = 1). Value is in range [-1, 1].
The Y rotation axis. Should be normalized (X^2 + Y^2 + Z^2 = 1). Value is in range [-1, 1].
The X rotation axis. Should be normalized (X^2 + Y^2 + Z^2 = 1). Value is in range [-1, 1].
{ "type": "object", "properties": { "angle": { "type": "number", "description": "The rotation angle.", "format": "double" }, "x": { "type": "number", "description": "The X rotation axis. Should be normalized (X^2 + Y^2 + Z^2 = 1). Value is in range [-1, 1].", "format": "double" }, "y": { "type": "number", "description": "The Y rotation axis. Should be normalized (X^2 + Y^2 + Z^2 = 1). Value is in range [-1, 1].", "format": "double" }, "z": { "type": "number", "description": "The X rotation axis. Should be normalized (X^2 + Y^2 + Z^2 = 1). Value is in range [-1, 1].", "format": "double" } }, "additionalProperties": false, "description": "Properties describing an objects' rotation." }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?