Gets all Animation Bindings of a Schedule.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
The $top system query option requests the number of items in the queried collection to be included in the result. When $top parameter is not provided default is set to 100. $top value cannot exceed 10000.
A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.
Format - date-time (as date-time in RFC3339). Filter for tasks. If a task's planned finish time is before the provided start time, animation bindings for the task are filtered out. Must be used together with endTime.
Format - date-time (as date-time in RFC3339). Filter for tasks. If a task's planned start time is after the provided end time, animation bindings for the task are filtered out. Must be used together with startTime.
Filter for tasks. Returns only those animation bindings which are related to the given task unique identifiers. Values of task unique identifiers should be comma separated without spaces.
Filter for animated entities. Returns only those animation bindings which are related to the given animated entity unique identifiers. Values of animated entity unique identifiers should be comma separated without spaces.
Request headers
A header that makes the request conditional. If the ETag of the requested resource or resource collection matches the provided value, a 304 (Not Modified) response is returned. For more information see the official documentation.
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "animationBindings": [{ "animatedEntityId": "0x20000000028", "appearanceProfileId": "d6003571-a494-4b5e-a6a5-466f18a84cc4", "pathAssignmentId": "b1f5e643-3ffe-4510-b56e-c2b39fee1131", "resourceAssignmentId": "1d32e2d4-a150-4c89-b522-85092a69c145", "resourceGroupId": "49aa4a19-e1ff-4a03-a97c-dff77b746761", "resourceId": "303b4183-d014-44b5-9002-54479681336f", "taskId": "77b25bc8-7553-4a88-9035-e46cfb4f05a1", "transformId": null }, { "animatedEntityId": "0x20000000024", "appearanceProfileId": "d4ad5630-69dc-49ce-b8f1-ad755603843a", "pathAssignmentId": null, "resourceAssignmentId": null, "resourceGroupId": null, "resourceId": "6de108ac-e464-427c-956e-50af2ad1020c", "taskId": "45b36a46-b906-404b-b51f-c91851a200dc", "transformId": "4a3c78fa-fa58-4af6-be48-1cf364a4c2b1" } ], "_links": { "self": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/animation-bindings?$top=2" }, "next": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/animation-bindings?$top=2&$continuationToken=eyJQcmltYXJ5U2tpcFRva2VuIjoiMDAwNGE5MDAtM2UxYy00NGNlLThhMzktYWUxZWRlY2M1MWY0IiwiU2Vjb25kYXJ5U2tpcFRva2VuIjpudWxsfQ==" } } }
Response headers
A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.
A header that identifies a specific version of a resource or resource collection. For more information see the official documentation.
Response 304 Not Modified
Not Modified
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
This response indicates that the provided Schedule is not available.
{ "error": { "code": "ScheduleNotFound", "message": "Requested Schedule is not available.", "target": "scheduleId" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidSchedulesRequest", "details": [{ "code": "InvalidValue", "message": "Top value is not positive, or exceeds maximum page size.", "target": "$top" }, { "code": "InvalidValue", "message": "Provided continuation token is invalid.", "target": "$continuationToken" }, { "code": "InvalidValue", "message": "Provided 'startTime' should be earlier than 'endTime'.", "target": "startTime" }, { "code": "InvalidValue", "message": "Provided 'endTime' should be later than 'startTime'.", "target": "endTime" }, { "code": "InvalidValue", "message": "Provided array exceeds the maximum size of 1000.", "target": "taskIds" }, { "code": "InvalidValue", "message": "Provided array exceeds the maximum size of 1000.", "target": "animatedEntityIds" } ], "message": "The request contains invalid properties." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Animation Binding
Properties defining how an Animated Entity is animated over the course of a Task.
The unique identifier of the Animated Entity. If the animated entity is an iModel element the ID will be in hexadecimal format e.g. '0x01'.
The unique identifier of the Appearance Profile.
The unique identifier of the Animation 3D Path Assignment.
The unique identifier of the Resource Assignment.
The unique identifier of the Resource Group.
The unique identifier of the Resource.
The unique identifier of the Task.
The unique identifier of the Animation 3D Transform.
{ "title": "Animation Binding", "type": "object", "properties": { "animatedEntityId": { "type": "string", "description": "The unique identifier of the Animated Entity. If the animated entity is an iModel element the ID will be in hexadecimal format e.g. '0x01'." }, "appearanceProfileId": { "type": "string", "description": "The unique identifier of the Appearance Profile." }, "pathAssignmentId": { "type": "string", "description": "The unique identifier of the Animation 3D Path Assignment.", "nullable": true }, "resourceAssignmentId": { "type": "string", "description": "The unique identifier of the Resource Assignment.", "nullable": true }, "resourceGroupId": { "type": "string", "description": "The unique identifier of the Resource Group.", "nullable": true }, "resourceId": { "type": "string", "description": "The unique identifier of the Resource." }, "taskId": { "type": "string", "description": "The unique identifier of the Task." }, "transformId": { "type": "string", "description": "The unique identifier of the Animation 3D Transform.", "nullable": true } }, "additionalProperties": false, "description": "Properties defining how an Animated Entity is animated over the course of a Task." }
Animation Bindings Response
List of Animation Bindings.
{ "title": "Animation Bindings Response", "type": "object", "properties": { "animationBindings": { "type": "array", "items": { "$ref": "#/components/schemas/AnimationBinding" }, "description": "A list of Animation Bindings." }, "_links": { "$ref": "#/components/schemas/PagingLinks", "description": "Contains the hyperlinks to the current and next pages of results." } }, "additionalProperties": false, "description": "List of Animation Bindings." }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false, "description": "Hyperlink container." }
Paging Links
URLs for redoing the current request and/or getting the next page of results if applicable.
{ "title": "Paging Links", "type": "object", "properties": { "self": { "$ref": "#/components/schemas/Link", "description": "Relative URL for redoing the current request." }, "next": { "$ref": "#/components/schemas/Link", "description": "Relative URL for getting the next page of results.", "nullable": true } }, "additionalProperties": false, "description": "URLs for redoing the current request and/or getting the next page of results if applicable." }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?