Gets all Appearance Profiles of a Schedule.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Appearance Profile Actions
Appearance profile Action describes how assigned resources are displayed before, during and after the assigned Task.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
The $top system query option requests the number of items in the queried collection to be included in the result. When $top parameter is not provided default is set to 100. $top value cannot exceed 10000.
A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.
Request headers
A header that makes the request conditional. If the ETag of the requested resource or resource collection matches the provided value, a 304 (Not Modified) response is returned. For more information see the official documentation.
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Response 200 OK
OK
{ "appearanceProfiles": [{ "action": "Install", "activeAppearance": { "color": "#00ff00", "finishTransparency": 53, "growthSimulation": { "adjustForTaskPercentComplete": true, "direction": { "x": 0.37139067, "y": 0.557086, "z": 0.74278134 }, "mode": "Custom", "pauseDuringNonWorkingTime": true, "simulateAsRemove": false }, "startTransparency": 15, "useOriginalColor": true, "useOriginalTransparency": false }, "createdOn": "2025-01-29T11:19:00Z", "endAppearance": { "color": "#00ced1", "transparency": 0, "useOriginalColor": false, "useOriginalTransparency": true }, "id": "3defd13b-ab0a-49fa-b3ba-37dd8b9532f1", "name": "Custom Profile 1", "parentId": null, "startAppearance": { "color": "#00ff00", "transparency": 0, "useOriginalColor": true, "useOriginalTransparency": true } }, { "action": "Maintain", "activeAppearance": { "color": "#00bfff", "finishTransparency": 0, "growthSimulation": { "adjustForTaskPercentComplete": false, "direction": { "x": 0, "y": 0, "z": 1 }, "mode": "RightLeft", "pauseDuringNonWorkingTime": true, "simulateAsRemove": true }, "startTransparency": 0, "useOriginalColor": false, "useOriginalTransparency": false }, "createdOn": null, "endAppearance": { "color": "#00ff00", "transparency": 70, "useOriginalColor": true, "useOriginalTransparency": false }, "id": "d6003571-a494-4b5e-a6a5-466f18a84cc4", "name": "Custom Profile 2", "parentId": null, "startAppearance": { "color": "#8a2be2", "transparency": 44, "useOriginalColor": false, "useOriginalTransparency": false } } ], "_links": { "self": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/appearance-profiles?$top=2" }, "next": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/appearance-profiles?$top=2&$continuationToken=eyJQcmltYXJ5U2tpcFRva2VuIjoiMDAwNGE5MDAtM2UxYy00NGNlLThhMzktYWUxZWRlY2M1MWY0IiwiU2Vjb25kYXJ5U2tpcFRva2VuIjpudWxsfQ==" } } }
Response headers
A token used for pagination to retrieve the next set of results. It indicates where the previous page of results ended, allowing you to fetch the subsequent batch of data.
A header that identifies a specific version of a resource or resource collection. For more information see the official documentation.
Response 304 Not Modified
Not Modified
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 404 Not Found
This response indicates that the provided Schedule is not available.
{ "error": { "code": "ScheduleNotFound", "message": "Requested Schedule is not available.", "target": "scheduleId" } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidSchedulesRequest", "details": [{ "code": "InvalidValue", "message": "Top value is not positive, or exceeds maximum page size.", "target": "$top" }, { "code": "InvalidValue", "message": "Provided continuation token is invalid.", "target": "$continuationToken" } ], "message": "The request contains invalid properties." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Active Appearance
Properties describing how the appearance of an object changes while assigned Task is in progress.
How transparent the object is in the end of the assigned Task. Value is in the range [0, 100], with 0 being completely opaque and 100 being completely transparent.
Growth simulation describes how the object grows while it is being installed or removed.
How transparent the object is in the start of the assigned Task. Value is in the range [0, 100], with 0 being completely opaque and 100 being completely transparent.
Use the original color of the object.
Use the original transparency of the object.
{ "title": "Active Appearance", "type": "object", "properties": { "color": { "$ref": "#/components/schemas/ColorRGB", "description": "The color of the object." }, "finishTransparency": { "type": "integer", "description": "How transparent the object is in the end of the assigned Task. Value is in the range [0, 100], with 0 being completely opaque and 100 being completely transparent.", "format": "int32" }, "growthSimulation": { "$ref": "#/components/schemas/ResourceGrowth", "description": "Growth simulation describes how the object grows while it is being installed or removed." }, "startTransparency": { "type": "integer", "description": "How transparent the object is in the start of the assigned Task. Value is in the range [0, 100], with 0 being completely opaque and 100 being completely transparent.", "format": "int32" }, "useOriginalColor": { "type": "boolean", "description": "Use the original color of the object." }, "useOriginalTransparency": { "type": "boolean", "description": "Use the original transparency of the object." } }, "additionalProperties": false, "description": "Properties describing how the appearance of an object changes while assigned Task is in progress." }
Appearance
The appearance of an object.
How transparent the object is. Value is in the range [0, 100], with 0 being completely opaque and 100 being completely transparent.
Use the original color of the object.
Use the original transparency of the object.
{ "title": "Appearance", "type": "object", "properties": { "color": { "$ref": "#/components/schemas/ColorRGB", "description": "The color of the object." }, "transparency": { "type": "integer", "description": "How transparent the object is. Value is in the range [0, 100], with 0 being completely opaque and 100 being completely transparent.", "format": "int32" }, "useOriginalColor": { "type": "boolean", "description": "Use the original color of the object." }, "useOriginalTransparency": { "type": "boolean", "description": "Use the original transparency of the object." } }, "additionalProperties": false, "description": "The appearance of an object." }
Appearance Profile
Representation of an Appearance Profile.
The action property indicates the display status of a resource in relation to a task's lifecycle.
The Active Appearance describes how assigned resources change while the assigned Task is in progress.
The date on which the Appearance Profile was created.
The unique identifier of the Appearance Profile.
The name of the Appearance Profile.
The unique identifier of the parent Appearance Profile.
{ "title": "Appearance Profile", "type": "object", "properties": { "action": { "$ref": "#/components/schemas/AppearanceProfileAction", "description": "The action property indicates the display status of a resource in relation to a task's lifecycle." }, "activeAppearance": { "$ref": "#/components/schemas/ActiveAppearance", "description": "The Active Appearance describes how assigned resources change while the assigned Task is in progress." }, "createdOn": { "type": "string", "description": "The date on which the Appearance Profile was created.", "format": "date", "nullable": true }, "endAppearance": { "$ref": "#/components/schemas/Appearance", "description": "The appearance of assigned resources after the assigned Task has passed." }, "id": { "type": "string", "description": "The unique identifier of the Appearance Profile." }, "name": { "type": "string", "description": "The name of the Appearance Profile.", "nullable": true }, "parentId": { "type": "string", "description": "The unique identifier of the parent Appearance Profile.", "nullable": true }, "startAppearance": { "$ref": "#/components/schemas/Appearance", "description": "The appearance of assigned resources before the assigned Task has started." } }, "additionalProperties": false, "description": "Representation of an Appearance Profile." }
Appearance Profile Action
Appearance Profile Action indicates the display status of a resource in relation to a task's lifecycle. See the Appearance Profile Actions section for details.
{ "title": "Appearance Profile Action", "enum": [ "Install", "Temporary", "Remove", "Maintain", "Neutral", "Unknown" ], "type": "string", "description": "Appearance Profile Action indicates the display status of a resource in relation to a task's lifecycle. See the [Appearance Profile Actions](#appearance-profile-actions) section for details." }
Appearance Profiles Response
List of Appearance Profiles.
{ "title": "Appearance Profiles Response", "type": "object", "properties": { "appearanceProfiles": { "type": "array", "items": { "$ref": "#/components/schemas/AppearanceProfile" }, "description": "A list of Appearance Profiles.", "nullable": true }, "_links": { "$ref": "#/components/schemas/PagingLinks", "description": "Contains the hyperlinks to the current and next pages of results." } }, "additionalProperties": false, "description": "List of Appearance Profiles." }
Color RGB
Growth Simulation Mode
The direction of Growth Simulation.
{ "title": "Growth Simulation Mode", "enum": [ "BottomTop", "TopBottom", "LeftRight", "RightLeft", "FrontBack", "BackFront", "Custom", "None", "Unknown" ], "type": "string", "description": "The direction of Growth Simulation." }
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false, "description": "Hyperlink container." }
Paging Links
URLs for redoing the current request and/or getting the next page of results if applicable.
{ "title": "Paging Links", "type": "object", "properties": { "self": { "$ref": "#/components/schemas/Link", "description": "Relative URL for redoing the current request." }, "next": { "$ref": "#/components/schemas/Link", "description": "Relative URL for getting the next page of results.", "nullable": true } }, "additionalProperties": false, "description": "URLs for redoing the current request and/or getting the next page of results if applicable." }
Resource Growth
A representation of how an object grows while it is installed or removed.
When this value is enabled the Growth Simulation is affected by the Task percent complete.
The direction vector of installation or removal. Should be used when the Mode property is set to 'Custom'.
When this value is enabled the Growth Simulation will be paused during non working hours.
When this value is enabled the Growth Simulation will appear as if the object is being removed.
{ "title": "Resource Growth", "type": "object", "properties": { "adjustForTaskPercentComplete": { "type": "boolean", "description": "When this value is enabled the Growth Simulation is affected by the Task percent complete." }, "direction": { "$ref": "#/components/schemas/Vector3d", "description": "The direction vector of installation or removal. Should be used when the Mode property is set to 'Custom'." }, "mode": { "$ref": "#/components/schemas/GrowthSimulationMode", "description": "The direction enum of installation or removal." }, "pauseDuringNonWorkingTime": { "type": "boolean", "description": "When this value is enabled the Growth Simulation will be paused during non working hours." }, "simulateAsRemove": { "type": "boolean", "description": "When this value is enabled the Growth Simulation will appear as if the object is being removed." } }, "additionalProperties": false, "description": "A representation of how an object grows while it is installed or removed." }
Vector 3D
A 3D vector.
The normalized X axis of the vector. The value is in the range [0, 1].
The normalized Y axis of the vector. The value is in the range [0, 1].
The normalized Z axis of the vector. The value is in the range [0, 1].
{ "title": "Vector 3D", "type": "object", "properties": { "x": { "type": "number", "description": "The normalized X axis of the vector. The value is in the range [0, 1].", "format": "double" }, "y": { "type": "number", "description": "The normalized Y axis of the vector. The value is in the range [0, 1].", "format": "double" }, "z": { "type": "number", "description": "The normalized Z axis of the vector. The value is in the range [0, 1].", "format": "double" } }, "additionalProperties": false, "description": "A 3D vector." }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?