Creates a Resource Status History Item for a Schedule.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Entity to post for creation.
Request body
Resource Status History Item Create Request
The date the Status change actually occurred.
The unique identifier of the Resource Status History Item.
The unique identifier of the Resource.
The unique identifier of the Resource Status Category.
The unique identifier of the Resource Status Item.
Example
{ "date": "2025-02-08T05:00:00Z", "id": "1604789f-68c4-46ba-b20d-8a19f8319362", "resourceId": "ffef8819-4bcd-404a-ba33-3a7c0b59679e", "statusCategoryId": "554043bf-c4e6-4cf0-85d8-8316c2ce808c", "statusItemId": "61486342-a67e-44f6-8126-ce6e33b6c3be" }
Response 202 Accepted
This response indicates that the requested long-running operation was Accepted.
{ "operation": { "id": "1604789f-68c4-46ba-b20d-8a19f8319362" }, "statusHistoryItem": { "id": "53d03dd8-941e-4663-995e-d23a306ee3b6" }, "_links": { "operationLocation": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/operations/1604789f-68c4-46ba-b20d-8a19f8319362" } } }
Response headers
The unique identifier of the Operation.
URL to the Operations endpoint with pre-entered Operation ID.
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to create a Resource Status History Item.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Schedule is not available.
{ "error": { "code": "ScheduleNotFound", "message": "Requested Schedule is not available.", "target": "scheduleId" } }
Response 409 Conflict
This response indicates that a changeset with provided Id already exists or provided Schedule is not initialized.
{ "error": { "code": "ScheduleNotInitialized", "message": "Provided Schedule is not initialized. Current Schedule state: 'Processing'." } }
Response 422 Unprocessable Entity
The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).
{ "error": { "code": "InvalidSchedulesRequest", "details": [{ "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "resourceId" }, { "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "date" }, { "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "statusItemId" } ], "message": "The request contains invalid properties." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false, "description": "Hyperlink container." }
Operation Create Response Properties
Contains the id of the created long-running operation.
The unique identifier of the Operation.
{ "title": "Operation Create Response Properties", "type": "object", "properties": { "id": { "type": "string", "description": "The unique identifier of the Operation.", "nullable": true } }, "additionalProperties": false, "description": "Contains the id of the created long-running operation." }
Operation Location
Contains the URL to the Operations endpoint to check the information about a long-running operation.
{ "title": "Operation Location", "type": "object", "properties": { "operationLocation": { "$ref": "#/components/schemas/Link", "description": "URL to the Operations endpoint with pre-entered Operation ID." } }, "additionalProperties": false, "description": "Contains the URL to the Operations endpoint to check the information about a long-running operation." }
Resource Status History Create Response
Contains properties of the created long-running operation, and a link to this operation.
Contains properties of the created long-running operation.
Contains the hyperlink to the Operations endpoint to check the operation information.
Properties of the Resource Status History item to be created.
{ "title": "Resource Status History Create Response", "type": "object", "properties": { "operation": { "$ref": "#/components/schemas/OperationCreateResponseProperties", "description": "Contains properties of the created long-running operation." }, "_links": { "$ref": "#/components/schemas/OperationLocationLink", "description": "Contains the hyperlink to the Operations endpoint to check the operation information." }, "statusHistoryItem": { "$ref": "#/components/schemas/ResourceStatusHistoryCreateResponseProperties", "description": "Properties of the Resource Status History item to be created." } }, "additionalProperties": false, "description": "Contains properties of the created long-running operation, and a link to this operation." }
Resource Status History Create Response Properties
Contains properties of the Resource Status History item that is queued for creation.
The unique identifier of the Resource Status History item.
{ "title": "Resource Status History Create Response Properties", "type": "object", "properties": { "id": { "type": "string", "description": "The unique identifier of the Resource Status History item." } }, "additionalProperties": false, "description": "Contains properties of the Resource Status History item that is queued for creation." }
Resource Status History Item Create Request
Properties of the Resource Status History Item to be created.
The date the Status change actually occurred.
The unique identifier of the Resource Status History Item.
The unique identifier of the Resource.
The unique identifier of the Resource Status Category.
The unique identifier of the Resource Status Item.
{ "title": "Resource Status History Item Create Request", "type": "object", "properties": { "date": { "type": "string", "description": "The date the Status change actually occurred.", "format": "date-time" }, "id": { "type": "string", "description": "The unique identifier of the Resource Status History Item.", "nullable": true }, "resourceId": { "type": "string", "description": "The unique identifier of the Resource." }, "statusCategoryId": { "type": "string", "description": "The unique identifier of the Resource Status Category.", "nullable": true }, "statusItemId": { "type": "string", "description": "The unique identifier of the Resource Status Item." } }, "additionalProperties": false, "description": "Properties of the Resource Status History Item to be created." }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?