Creates a Task for a Schedule.
Tasks are but not limited to portions of work that are used to help determine the overall workload required and timeframe needed to complete the project.
Task Types
Tasks can be of differing types. The following Task types have different behaviors:
- Work: The default Task type. Work represents an expenditure of effort and resources achieving the Task. Work type Tasks have a Start, Finish and a Duration.
- StartKeyDate: A Project Milestone - setting a Task as a Key Date will also change its representation in the Gantt Chart to a diamond, and give the Task a zero duration. Start Key Dates have no Finish Date or Duration.
- FinishKeyDate: A Project Milestone - setting a Task as a Key Date will also change its representation in the Gantt Chart to a diamond, and give the Task a zero duration. Finish Key Dates have no Start Date or Duration.
- ShortHammock: Spans the shortest duration between all its predecessor and successor Tasks. The Start, Finish, and Duration of the Short Hammock is derived from its predecessor and successor Tasks and cannot be edited directly.
- LongHammock: Spans the longest duration between all its predecessor and successor Tasks. The Start, Finish, and Duration of the Long Hammock is derived from its predecessor and successor Tasks and cannot be edited directly
The remaining Task Types behave the same as the Work type and can be used to help label Tasks.
Operation
Operations, also known as LROs (Long Running Operations), are time-consuming tasks that would not be completed in the appropriate timeframe for a single request response. Endpoints that use operations return an operation id that can be used on a separate endpoint to track the progress of the task that is being handled.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request parameters
The unique identifier of the Schedule.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Request body
Task Create Request
The comment of the Task. The comment cannot exceed 1000 characters.
The unique identifier of the Task.
The name of the Task.
The unique identifier of the parent Task.
The time allotted to complete a Task. It can only change for Tasks with Planned Status. The value is a timestamp of seconds.
The Start Date of the Task.
A URL associated with the Task.
A unique Task Id defined by the user.
Example
{ "comment": "Comment about demolishing", "id": "fc3673d9-e385-4031-abbe-663535a329f5", "name": "Demolish Old Building", "parentId": "e3e4f597-8b58-4c0a-8931-1f3f55a7b34b", "plannedDuration": 144000, "plannedStart": "2019-12-02T08:00:00Z", "type": "Work", "url": "https://example.com", "userDefinedId": "D256" }
Response 202 Accepted
This response indicates that the requested long-running operation was Accepted.
{ "operation": { "id": "1604789f-68c4-46ba-b20d-8a19f8319362" }, "task": { "id": "fc3673d9-e385-4031-abbe-663535a329f5" }, "_links": { "operationLocation": { "href": "https://api.bentley.com/schedules/5e11b21e-cba2-48a8-a2c1-2977d2d373e0/operations/1604789f-68c4-46ba-b20d-8a19f8319362" } } }
Response headers
The unique identifier of the Operation.
URL to the Operations endpoint with pre-entered Operation ID.
Response 400 Bad Request
The 400 (Bad Request) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)
{ "error": { "code": "InvalidSchedulesRequest", "details": [{ "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "name" }, { "code": "MissingRequiredProperty", "message": "A required property is missing or empty.", "target": "type" } ], "message": "The request contains invalid properties." } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
User is not authorized to create a Task.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Schedule is not available.
{ "error": { "code": "ScheduleNotFound", "message": "Requested Schedule is not available.", "target": "scheduleId" } }
Response 409 Conflict
This response indicates that a changeset with provided Id already exists or provided Schedule is not initialized.
{ "error": { "code": "ScheduleNotInitialized", "message": "Provided Schedule is not initialized. Current Schedule state: 'Processing'." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Link
Hyperlink container.
Hyperlink to the specific entity.
{ "type": "object", "properties": { "href": { "type": "string", "description": "Hyperlink to the specific entity." } }, "additionalProperties": false, "description": "Hyperlink container." }
Operation Create Response Properties
Contains the id of the created long-running operation.
The unique identifier of the Operation.
{ "title": "Operation Create Response Properties", "type": "object", "properties": { "id": { "type": "string", "description": "The unique identifier of the Operation.", "nullable": true } }, "additionalProperties": false, "description": "Contains the id of the created long-running operation." }
Operation Location
Contains the URL to the Operations endpoint to check the information about a long-running operation.
{ "title": "Operation Location", "type": "object", "properties": { "operationLocation": { "$ref": "#/components/schemas/Link", "description": "URL to the Operations endpoint with pre-entered Operation ID." } }, "additionalProperties": false, "description": "Contains the URL to the Operations endpoint to check the information about a long-running operation." }
Task Create Request
Properties of the Task to be created.
The comment of the Task. The comment cannot exceed 1000 characters.
The unique identifier of the Task.
The name of the Task.
The unique identifier of the parent Task.
The time allotted to complete a Task. It can only change for Tasks with Planned Status. The value is a timestamp of seconds.
The Start Date of the Task.
A URL associated with the Task.
A unique Task Id defined by the user.
{ "title": "Task Create Request", "type": "object", "properties": { "comment": { "type": "string", "description": "The comment of the Task. The comment cannot exceed 1000 characters.", "nullable": true }, "id": { "type": "string", "description": "The unique identifier of the Task.", "nullable": true }, "name": { "type": "string", "description": "The name of the Task." }, "parentId": { "type": "string", "description": "The unique identifier of the parent Task.", "nullable": true }, "plannedDuration": { "type": "integer", "description": "The time allotted to complete a Task. It can only change for Tasks with Planned Status. The value is a timestamp of seconds.", "format": "int32", "nullable": true }, "plannedStart": { "type": "string", "description": "The Start Date of the Task.", "format": "date-time" }, "type": { "$ref": "#/components/schemas/TaskType", "description": "The type of the Task." }, "url": { "type": "string", "description": "A URL associated with the Task.", "nullable": true }, "userDefinedId": { "type": "string", "description": "A unique Task Id defined by the user.", "nullable": true } }, "additionalProperties": false, "description": "Properties of the Task to be created." }
Task Create Response
Contains properties of the created long-running operation, and a link to this operation.
Contains properties of the created long-running operation.
Contains the hyperlink to the Operations endpoint to check the operation information.
{ "title": "Task Create Response", "type": "object", "properties": { "operation": { "$ref": "#/components/schemas/OperationCreateResponseProperties", "description": "Contains properties of the created long-running operation." }, "task": { "$ref": "#/components/schemas/TaskCreateResponseProperties", "description": "Properties of the Task to be created." }, "_links": { "$ref": "#/components/schemas/OperationLocationLink", "description": "Contains the hyperlink to the Operations endpoint to check the operation information." } }, "additionalProperties": false, "description": "Contains properties of the created long-running operation, and a link to this operation.", "x-codegen-extends-class": "OperationCreateResponse" }
Task Create Response Properties
Contains properties of the Task that is queued for creation.
The unique identifier of the Task.
{ "title": "Task Create Response Properties", "type": "object", "properties": { "id": { "type": "string", "description": "The unique identifier of the Task." } }, "additionalProperties": false, "description": "Contains properties of the Task that is queued for creation." }
Task Type
Task Type provides a categorization (or classification) of project Tasks. See the Task Types section for details.
{ "title": "Task Type", "enum": [ "Work", "StartKeyDate", "FinishKeyDate", "ShortHammock", "LongHammock", "Rfi", "ChangeOrder", "Testing", "Delivery", "Meeting", "Rework", "Design", "Maintenance", "Manufacture", "Storage", "Purchase", "Receive", "Delay", "WeatherDelay", "Unknown" ], "type": "string", "description": "Task Type provides a categorization (or classification) of project Tasks. See the [Task Types](#task-types) section for details." }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?