GET https://dev-api.bentley.com/storage/?iTwinId[&$top][&$skip]
Retrieves all files and folders stored at the root level of your iTwin using the iTwinId.
The Root Folder serves as the primary directory for your iTwin, identified by the iTwinId.
Root Folder: Base folder created when iTwin is created.
While the old endpoint remain supported for backward compatibility, we strongly recommend transitioning to the new endpoints to take full advantage of the latest features and improvements.
Old Endpoints: https://api.bentley.com/storage/?projectId={PROJECT_ID}
Parameters: projectId - id of the project.
Status: Supported
New Endpoints: https://api.bentley.com/storage/?iTwinId={ITWIN_ID}
User must be an Organization Administrator for the Organization that owns a given Project or have storage_read permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
json
HeaderNotFound
{"error":{"code":"HeaderNotFound","message":"Header Authorization was not found in the request. Access denied."}}
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.