Update the file.
As shown in the request section below, you must provide an updated request body.
The displayName
MUST be provided in the request body, and the fileId
MUST be provided in the parameters.
Parameters
fileId
– Id of the file which you want to update.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_write
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Errors
This request can return InvalidCreateFileRequest error with 422 status code. This could happen because of these reasons:
- File name contains invalid characters.
- File name's length is larger than 255 characters.
- File could be harmful. For example, executable files are not accepted.