Update file's content
As shown in the request section below, you must provide a request body.
The displayName
MUST be provided in the request body, and the fileId
MUST be provided in the parameters.
Parameters
fileId
– Id of the file in which you want to update the content.
Notes
File update is a three step process. This request creates hyperlinks for file content update and confirmation.
Next two requests need to be executed by using links from the response. Maximum file size to upload with single request is 256 MiB. If bigger files needs to uploaded there are possibility to use Azure libraries or by uploading file with multiple requests.
uploadUrl is required for file upload. Upload can be done by sending http PUT request and specifying
x-ms-blob-type
header toBlockBlob
. You can use Postman, Azcopy or any libraries with support Azure blob upload to upload the file to provided uploadUrl.completeUrl is used to confirm file upload and it is final request for file creation.
Maximum file size to upload with single request is 256 MiB. If bigger file needs to be uploaded there are ways to use Azure libraries to upload file via given Azure SAS url or by uploading file with multiple requests.
For large size file upload you can upload the file in chunks using FileStream depending on the tech-stack you are using.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have storage_write
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.