Use this endpoint to create CombinePhysicalModelsV2 configuration.
Combine Physical Models V2 transformation combines models in source iModel based on the EC query into target physical models with specified names. It is mandatory to only create source model queries which select ECInstanceId by using *
or explicitly selecting that column. Also, source queries must pick only physical models that are sub-modeling physical partition.
For more information about internal iModel structure, see Example Information Hierarchy.
This transformation allows to optimize iModel for better viewing performance. You can notice lack of performance when model count reaches ~1000 or even more models. You can select ~ 5-20 models by EC query and test the performance of the iModel.
Explanation of specific properties configuration.
modelGroups - property specifies an array of target model names with source model queries that you want to transform. This property is required.
groupUnselectedModels - optional parameter which indicates your decision on grouping unselected models. Default value is false.
unselectedModelsGroupName - optional parameter which sets name for unselected models group. You must specify the name if groupUnselectedModels is true.
simplifyGeometry - optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.
In addition to exported data, the transformer will also push some additional metadata. This metadata contains:
BisCore:RepositoryLink
andBisCore:ExternalSource
elements that mark the source where the data was imported from.- A "Scope"
BisCore:ExternalSourceAspect
that contains Synchronization changeset metadata that is needed by the transformation service to process any later changes correctly. - Element provenance information (
BisCore:ExternalSourceAspects
) for elements that do not have federation guids.
Transformations service creates an Editing Channel with key IModelTransformations
. All source iModel data is exported under a channel root subject named IModelTransformationsChannel
.
Read more about Editing Channels here.
Note: Creating a configuration does not run the transformation. To run the transformation, please see transformations reference.
Authentication
Requires Authorization
header with valid Bearer token for scope itwin-platform
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
You must have imodels_write
assigned at the target project level and imodels_read
assigned at the source project level within related configuration. If permissions at the project level are not configured, then you must have same assigned at the iModel level.
Alternatively, you must be an Organization Administrator for the Organization that owns a given project the iModel belongs to.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management see Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.
Request headers
OAuth access token with itwin-platform
scope
Setting to application/vnd.bentley.itwin-platform.v1+json
is recommended.
Configuration data
Request body
Create combine physical models v2 configuration
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Combine physical models v2 configuration transform parameters
Example
{ "transformName": "Example name", "sourceProjectId": "00000000-0000-0000-0000-000000000000", "sourceIModelId": "00000000-0000-0000-0000-000000000000", "targetProjectId": "00000000-0000-0000-0000-000000000000", "targetIModelId": "00000000-0000-0000-0000-000000000000", "comment": "Example comment", "transformParameters": { "modelGroups": [{ "targetModelName": "Grouped Section A", "sourceModelQuery": "SELECT ECInstanceId from bis.PhysicalPartition where UserLabel like 'A_Section%'" }, { "targetModelName": "Grouped Section B", "sourceModelQuery": "SELECT * from bis.PhysicalPartition where UserLabel like 'B_Section%'" } ], "groupUnselectedModels": true, "unselectedModelsGroupName": "Unselected models", "simplifyGeometry": true } }
Response 201 Created
Returns the created configuration.
{ "configuration": { "id": "00000000-0000-0000-0000-000000000000", "transformName": "Transformation name", "comment": "comment", "createdDateTime": "2021-08-02T14:51:33.6133333Z", "modifiedDateTime": "2021-08-02T14:52:33.6133333Z", "transformType": "CombinePhysicalModelsV2", "transformParameters": { "modelGroups": [{ "targetModelName": "Grouped Section A", "sourceModelQuery": "SELECT ECInstanceId from bis.PhysicalPartition where UserLabel like 'A_Section%'" }, { "targetModelName": "Grouped Section B", "sourceModelQuery": "SELECT * from bis.PhysicalPartition where UserLabel like 'B_Section%'" } ], "groupUnselectedModels": true, "unselectedModelsGroupName": "Unselected models", "simplifyGeometry": true }, "_links": { "sourceIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "targetIModel": { "href": "https://api.bentley.com/imodels/00000000-0000-0000-0000-000000000000" }, "sourceProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" }, "targetProject": { "href": "https://api.bentley.com/itwins/00000000-0000-0000-0000-000000000000" } } } }
Response 401 Unauthorized
This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.
{ "error": { "code": "HeaderNotFound", "message": "Header Authorization was not found in the request. Access denied." } }
Response 403 Forbidden
The user has insufficient permissions for the requested operation.
{ "error": { "code": "InsufficientPermissions", "message": "The user has insufficient permissions for the requested operation." } }
Response 404 Not Found
This response indicates that the provided Project or iModel could not be found.
{ "error": { "code": "IModelNotFound", "message": "Requested IModel is not available." } }
Response 422 Unprocessable Entity
Given data is invalid.
{ "error": { "code": "MissingRequestBody", "message": "Request body was not provided." } }
Response 429 Too many requests
This response indicates that the client sent more requests than allowed by this API for the current tier of the client.
{ "error": { "code": "RateLimitExceeded", "message": "The client sent more requests than allowed by this API for the current tier of the client." } }
Response headers
Number of seconds to wait until client is allowed to make more requests.
Create combine physical models v2 configuration
Data needed to create combine physical models v2 configuration.
User friendly name of the transformation.
ProjectId of the source iModel.
ID of the source iModel.
ProjectId of the target iModel.
ID of the target iModel.
Comment for the changeset created after transformation.
Combine physical models v2 configuration transform parameters
{ "type": "object", "title": "Create combine physical models v2 configuration", "description": "Data needed to create combine physical models v2 configuration.", "required": [ "comment", "sourceProjectId", "sourceIModelId", "targetProjectId", "targetIModelId", "transformName", "transformParameters" ], "properties": { "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "sourceProjectId": { "type": "string", "description": "ProjectId of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "sourceIModelId": { "type": "string", "description": "ID of the source iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetProjectId": { "type": "string", "description": "ProjectId of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "targetIModelId": { "type": "string", "description": "ID of the target iModel.", "example": "00000000-0000-0000-0000-000000000000" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "example": "Example comment" }, "transformParameters": { "description": "Combine physical models v2 configuration transform parameters", "$ref": "#/components/schemas/TParams_CombinePhysicalModelsV2" } }, "additionalProperties": false }
Combine physical models v2 configuration
Indicates if unselected models must be grouped
Name of unselected models group. Must be specified if groupUnselectedModels is set to true.
optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false.
{ "type": "object", "title": "Combine physical models v2 configuration", "properties": { "modelGroups": { "type": "array", "description": "Array of model groups", "items": { "$ref": "#/components/schemas/TParams_CombinePhysicalModelsV2_GroupUnselectedModels" } }, "groupUnselectedModels": { "type": "boolean", "description": "Indicates if unselected models must be grouped" }, "unselectedModelsGroupName": { "type": "string", "description": "Name of unselected models group. Must be specified if groupUnselectedModels is set to true." }, "simplifyGeometry": { "type": "boolean", "description": "optional parameter indicating if geometry simplification should be used (transforming parasolids to meshes). Default if not specified - false." } }, "required": [ "modelGroups" ], "additionalProperties": false }
Group unselected models properties
Name for grouped models
Query for grouping models
{ "type": "object", "title": "Group unselected models properties", "properties": { "targetModelName": { "type": "string", "description": "Name for grouped models" }, "sourceModelQuery": { "type": "string", "description": "Query for grouping models" } }, "additionalProperties": false }
Combine physical models v2 configuration response
{ "type": "object", "title": "Combine physical models v2 configuration response", "required": [ "configuration" ], "properties": { "configuration": { "description": "Combine physical models v2 configuration object", "$ref": "#/components/schemas/Configuration_CombinePhysicalModelsV2" } }, "additionalProperties": false }
Combine physical models v2 configuration properties
ID of the configuration.
User friendly name of the transformation.
Comment for the changeset created after transformation.
Time the configuration was created at.
Time the configuration was last modified at.
Type of the transformation.
Combine physical models v2 configuration transform parameters.
{ "type": "object", "title": "Combine physical models v2 configuration properties", "required": [ "id", "transformName", "comment", "createdDateTime", "modifiedDateTime", "transformParameters", "transformType", "_links" ], "properties": { "id": { "type": "string", "description": "ID of the configuration.", "example": "00000000-0000-0000-0000-000000000000" }, "transformName": { "type": "string", "description": "User friendly name of the transformation.", "example": "Example name" }, "comment": { "type": "string", "description": "Comment for the changeset created after transformation.", "nullable": true, "example": "Example comment" }, "createdDateTime": { "type": "string", "description": "Time the configuration was created at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "modifiedDateTime": { "type": "string", "description": "Time the configuration was last modified at.", "format": "date-time", "example": "0000-00-00T00:00:00.0000000Z" }, "transformType": { "type": "string", "description": "Type of the transformation.", "example": "FilterIModel" }, "transformParameters": { "description": "Combine physical models v2 configuration transform parameters.", "$ref": "#/components/schemas/TParams_CombinePhysicalModelsV2" }, "_links": { "description": "Links to a configuration data.", "$ref": "#/components/schemas/Links_ConfigurationData" } }, "additionalProperties": false }
Links
{ "type": "object", "title": "Links", "properties": { "sourceIModel": { "description": "Link to a source iModel.", "$ref": "#/components/schemas/Link" }, "targetIModel": { "description": "Link to a target iModel.", "$ref": "#/components/schemas/Link" }, "sourceProject": { "description": "Link to a source project.", "$ref": "#/components/schemas/Link" }, "targetProject": { "description": "Link to a target project.", "$ref": "#/components/schemas/Link" } }, "additionalProperties": false }
Link
Link to a resource.
{ "type": "object", "title": "Link", "properties": { "href": { "type": "string", "description": "Link to a resource." } }, "additionalProperties": false }
DetailedError
Contains error information and an array of more specific errors.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information and an array of more specific errors.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true }, "details": { "type": "array", "description": "Optional array of more specific errors.", "items": { "$ref": "#/components/schemas/Error" } } }, "required": [ "code", "message", "details" ], "additionalProperties": true }
Detailed Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Detailed Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error Detailed information.", "$ref": "#/components/schemas/DetailedError" } }, "required": [ "error" ], "additionalProperties": false }
Error
Contains error information.
One of a server-defined set of error codes.
A human-readable representation of the error.
The target of the error.
{ "type": "object", "description": "Contains error information.", "properties": { "code": { "type": "string", "description": "One of a server-defined set of error codes." }, "message": { "type": "string", "description": "A human-readable representation of the error." }, "target": { "type": "string", "description": "The target of the error.", "nullable": true } }, "required": [ "code", "message" ], "additionalProperties": true }
Error Response
Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.
{ "type": "object", "title": "Error Response", "description": "Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.", "properties": { "error": { "description": "Error information.", "$ref": "#/components/schemas/Error" } }, "required": [ "error" ], "additionalProperties": false }
Was this page helpful?